删除文章

确定要删除这篇文章吗?

取消
确定

linux问题汇总

     阅读(634)  2018-11-27 01:13:00

Unable to find remote helper for 'https'

是因为/usr/libexec/git-core路径没在 PATH 环境变量中,这导致里面的 git-remote-https, git-remote-http 这些得不到执行。所以git所表现出来的功能不全。

解决方法:
将 /usr/libexec/git-core 纳入 PATH,至少在使用 git 之前,设置一下PATH。

PATH=$PATH:/usr/libexec/git-core

或者直接在/etc/profile中修改

/bin/bash^M: bad interpreter: No such file or directory

大概率是从windows上将文件上传到linux导致的编码问题

解决方法:
安装dos2unix:

ubuntu:
apt install dos2unix
redhat:
yum install dos2unix
转换文件编码:
dos2unix xxx.sh

文章评论

Keep it simple,stupid
文章数
326
今日访问
821
今日IP数
227
最近评论

liangzi: 不错 谢谢分享
tujiaw: registerThreadInactive:如果当前没有激活的线程,就去激活线程,让等待的线程去执行任务。
hgzzx: 佩服佩服。 请教:registerThreadInactive的作用是什么?
xuehaoyun: 很不错,来围观一下
tujiaw: 抱歉csdn code服务关闭了,这个代码我也找不到了
于淞: 你好,这个文章的源码能分享一下吗,songsong9181@163.com,谢谢了 上面的写错了
回到顶部